Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 17, 2025 - 20:00 CET
Scheduled
The enhanced logging for our queueable framework from the Nov. 25 release led to unexpected changes in how certain exceptions are handled. This resulted in some installments potentially being left out of the schedule scope or otherwise failing unexpectedly. This hotfix resolves the issues for the impacted packages: Core (fix for Fundraising and NPSP), Gift Aid, and GoCardless. FinDock Support is reaching out to affected customers directly with more details.
With the introduction of Stripe Pre-Authorized Debit (PAD) support in the Nov. 25 release, the Custom Reference field from Mandate was added to all Stripe callouts. This caused recurring payment collections to fail if Custom Reference was already used for other purposes. This hotfix adjusts the callout message to only include Mandate Custom Reference for the PAD payment method. ACTION REQUIRED FOR STRIPE: If you use Custom Reference on Mandate for payment methods other than PAD, check for failed installments of recurring payments (with payment method other than PAD) since Nov. 30th. If you identify such installments, change the status to Pending recollection and run a new payment schedule to collect the installments.
Posted Dec 17, 2025 - 17:01 CET
This scheduled maintenance affected: FinDock Core & Source packages and (Online) Payment API / Payment Service Providers.