Due to a high risk issue with Salesforce related to permission set groups, we are not pushing the November '24 release to production this Sunday. For further details, please see our General Announcement: https://docs.findock.com/faq/november-24-release-announcement
Posted Nov 22, 2024 - 16:00 CET
Scheduled
The FinDock November '24 release will be pushed to Production. During this event features will be available with no disruptions in services. The release notes will be available on docs.findock.com the Wednesday before the Sandbox release.
Posted Dec 13, 2023 - 21:53 CET
This scheduled maintenance affected: FinDock Core & Source packages, File processing (ProcessingHub), (Online) Payment API / Payment Service Providers, Notifications from Payment Service Providers (WebHub), Giving pages, and Sandboxes.