Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2025 - 17:00 CEST
Scheduled
After the permissions data export hotfix on Oct. 8th, some customers experienced high batch API usage from our data export, potentially causes overall usage to exceed Salesforce licensed limits. The issue occurred when an org has extremely high numbers of permission assignments, well into the millions. This hotfix optimizes permission data syncing is to ensure API batch limits are not exceeded due to FinDock data exports.
Posted Oct 23, 2025 - 14:26 CEST
This scheduled maintenance affected: File processing (ProcessingHub) and Sandboxes.